Website down
Incident Report for SecurityTrails
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 11:48 UTC
Update
The website is up, we are investigating.
Posted Jun 26, 2024 - 11:38 UTC
Update
We are continuing to investigate this issue.
Posted Jun 26, 2024 - 11:19 UTC
Investigating
We are currently investigating this issue.
Posted Jun 26, 2024 - 11:16 UTC
This incident affected: Website & Public App, SecurityTrails Account Console, Attack Surface Intelligence & SurfaceBrowser™, and SecurityTrails Feeds™.